Travel – 10 hours, 3 buses, 1 train

Posted by Greg Fischer   @   5 March 2013 2 comments

As a rule I don’t go out of my way to ride a bus.  Nothing against them, but they just don’t move me in quite the same way that trains do.

With that said, I was intrigued when I read not long ago that Megabus had come back to California.  They dipped their toe in the water here in 2007-2008 and then withdrew, but reentered the market in late 2012.  The British company has been successful on the East Coast and elsewhere in the U.S. so I wanted to see how it worked from a passenger’s perspective as well as compare it with Amtrak’s Capitol Corridor service which I’ve used many times.

The closest route to where I live in Chico is the one between Sacramento and San Francisco.  Flipping back and forth between Megabus schedules and Amtrak schedules I put together an itinerary that, if everything worked as planned, would get me from Chico to San Francisco and back, in about 10 hours.  (And qualify me for being institutionalized, some people may think.)

Guess what?  The tight schedule I planned worked well.  I’ll summarize the journey below, and if you want more details please click on the link at the end of the post.

 

Bus – Amtrak 3714 – Chico to Sacramento

leave 7:50 am – arrive 9:55 am


Bus – Megabus – Sacramento to San Francisco

leave 10:50 am – arrive 12:45 pm


(BART from San Francisco to Richmond)


Rail – Amtrak 532 – Richmond to Sacramento

leave 1:47 pm – arrive 3:28 pm


Bus – Amtrak 3713 – Sacramento to Chico

leave 3:40 pm – arrive 5:35 pm

 

Now for the details.  Click here to go over to my other blog to read all about it if you dare.

Filed in Rail , Travel - Other 2 comments

2 Comments

Comments
Jun 20, 2013
7:44 am

Heya just wanted to give you a brief heads up and let
you know a few of the images aren’t loading properly. I’m not sure why but I think its
a linking issue. I’ve tried it in two different internet browsers and both show the same results.

Jun 20, 2013
11:20 am
#2 Greg Fischer :

Thanks for your comment. I think this post loads images fine in both Firefox and Explorer. Unfortunately earlier posts have many problems with images. The Enterprise-Record originally used Movable Type as its platform for bloggers, but a year or so ago switched to WordPress and the transition has been frustrating. The URLs all changed (thus making links from one post to another useless) and most of the images no longer load, but simply present a white, blank spot where the photo should be. I found Movable Type easier to use – I don’t love WordPress at all.

Sorry, comments are closed.

Previous Post
«
Next Post
»
G-scale designed by Make Your Own Website In conjunction with Web Hosting   |   Watch Movies Online   |   Computer Repair